?

Log in

No account? Create an account

Whatever Matt Feels Like Posting

This is where I post my incoherent ramblings. It's where I post the coherent ones, too!


September 6th, 2017

YAY!!! @ 04:55 pm

Right now I am annoyingly: relieved THANK YOU

I might still have to change http to https manually in all my entries to make userpics show up (and all the other things I've been meaning to update in my entries for years), but LJ fixed the bug where images hosted on other sites wouldn't show up! Yay!!!!

 
Spread the word  |  |

Comments

 
[User Picture Icon]
From:kristy
Date:September 6th, 2017 10:58 pm (UTC)
(Link)

I'm glad your images work but I'm confused on why you'd have to change the coding in user pics, that are uploaded directly from the user pic link on lj. Sorry. I'm blonde.

[User Picture Icon]
From:matt1993
Date:September 7th, 2017 12:14 am (UTC)
(Link)
↑ I've had no problems at all using userpics as userpics on entries or comments (i.e. up here). What I'm having problems with is using userpics in the body of an entry or comment (most notably in my sticky "list of userpics in order added" post, which looked fine until a few days ago).

Using <img src="http://l-userpic.livejournal.com/95214823/13627499"> in an entry or comment gives:



Unless they fixed it at some point after I posted this comment, this is a broken image. This would not have been the case before... I don't know what day, but it must've been between August 1 and September 2.

Using <img src="https://l-userpic.livejournal.com/95214823/13627499"> in an entry or comment, however, gives:



This version works - but there's only a few cases in my entries or comments where it was https all along, so I'm going to have to fix all the rest (and a bunch of other things I've been meaning to fix in my old entries for years).

Edited at 2017-09-07 12:15 am (UTC)
[User Picture Icon]
From:matt1993
Date:September 7th, 2017 12:23 am (UTC)
(Link)
Oh, and this'll probably better answer your question: LiveJournal uses HTTPS instead of HTTP now, and the problem probably has something to do with the transition.
[User Picture Icon]
From:kristy
Date:September 7th, 2017 12:25 am (UTC)
(Link)
I knew that about 4 days ago!

Hehe...
[User Picture Icon]
From:kristy
Date:September 7th, 2017 12:25 am (UTC)
(Link)
Ahhh. I understand now.

I've been fixing some broken images as well.
[User Picture Icon]
From:pathvain_aelien
Date:September 7th, 2017 12:17 am (UTC)
(Link)
:)

Whatever Matt Feels Like Posting

This is where I post my incoherent ramblings. It's where I post the coherent ones, too!